Get in touch
Back
Downtime

Websites and Emails are down

Started 11 Feb at 04:25am GMT, resolved 11 Feb at 04:54am GMT.

Websites Emails
Resolved

Websites and Emails recovered.

Posted 11 Feb at 04:54am GMT.
Created

This was caused by a temporary outage with our hosting provider Digital Ocean.

Posted 11 Feb at 04:25am GMT.